Google Plugin for Eclipse – jar has been tampered!


While installing Google Plugin for Eclipse 3.7, via , it took almost half and hour and download and stopped at the end.

A long list of error messages “.jar has been tampered!” are prompted in Eclipse.

An error occurred while collecting items to be installed
session context was:(profile=epp.package.jee,
phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
No repository found containing: osgi.bundle,org.eclipse.m2e.maven.indexer,
Retry another mirror
Problems downloading artifact: osgi.bundle,org.eclipse.m2e.maven.runtime,
File has invalid content:C:\Users\mkyong\AppData\Local\Temp\signatureFile755577951398164410.jar
Invalid content:jars/aether-connector-wagon-1.11.jar
The file "jars/aether-connector-wagon-1.11.jar" in the jar "C:\Users\mkyong\AppData\Local
has been tampered!
Invalid content:jars/guice-plexus-shim-2.0.0.jar
Invalid content:jars/maven-aether-provider-3.0.2.jar
The file "jars/maven-aether-provider-3.0.2.jar" in the jar "C:\Users\mkyong\AppData\Loca
has been tampered!
Invalid content:jars/sisu-guice-2.9.4-no_aop.jar


From this thread, the JDK/JRE 7 will caused the Google plugin for Eclipse failed to download.

To solve it, change the Eclipse’s JRE back to more stable version, like JRE 6.

change jre in eclipse change jre in eclipse

Leave a Reply

Fill in your details below or click an icon to log in: Logo

You are commenting using your account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s